Flash Player installation warning

Due to absence of Flash Player, the user could not load the game in Firefox… The user tried to install Flash player from EteRNA home site, but she downloaded the older version.

Firefox Version: 3.06.12
Flash Player version detected : 10.0.12.36

We should recommend Flash player version greater than 10.1

For future reference:
Use this trouble shooting link to check the installed flash player version:
https://www.cmu.edu/iso/patch-check/c…?

or Ask your to a user to Visit
http://kb2.adobe.com/cps/155/tn_15507…

I’d like to add that Adobe has changed its End User License Agreement with expanded intrusion of your privacy with version 10.1, do read up on the EULA on the adobe webpage to be fully aware of that you are agreeing to. This is a chage from version 9.