Locked bases in 'lab puzzles' have changed

not sure how signifcant this is but


is a ‘lab puzzle’ and the locked bases are no longer the same locked bases as they used to be - they are now all showing as Adenine

if this has happened in other ‘lab type’ player puzzles then some may now be easier/impossible

If i remember correctly both the newly-locked base and the FMN binding site lie at the side of the 6-5 loop that faces the hairpin.

Maybe the idea was to keep that region close to how it appears in the reference - with a UA pair closing the loop.

Hi Quasi - not what I meant

check out the link http://eterna.cmu.edu//sites/default/… - the hook area was full of locked A for some reason - and still is

I just tried to recreate the puzzle and I get a different screen shot

with the hook area having the usual 2 reds and extra greens hanging around in the locked hook.

That means that somehow the puzzle called ‘moderately easy’ changed after I first submitted it. I’m guessing it would not be a one off - and that other puzzles might also have that change - making them easier/harder.

I just resubmitted the same shape (plus one base in a large loop) - can confirm that also only shows AAAA in the locked bases despite the puzzle I solved having the other bases locked - that might accidentally make some puzzles (where the hook free energy level is significant) actually impossible to solve


you mean the locked bases looked completely normal before you submitted the puzzle, and the locks changed its colors after you submitted it?

Can you try to remember how you made that happen?

yes - that’s what I mean
I just solved the puzzle (I just solved it quickly as a christmas tree with all ‘right turning’ GC pairs and optimal red boosts, might have had to reverse the gc pair nearest the neck in the first multiloop) and it was all looking correct (with the red and green present in the locked bases) - then I hit submit and when I went to the player puzzle tab to see if it was still the same - it was not and now the hook was all AAA

I can’t remember for certain but I’m 95% sure that the bases had not changed while I was still on the page after submitting but before looking in the player puzzle tab.

it it makes any difference I’m on mozilla with an old winxp machine and the latest flash player (not the debug version here -sorry)

ok further detail - I clicked Yes to the question ‘do you want to design a puzzle as a lab candidate’ then pasted in a sequence, then ammended it (using the pink add a base button), then solved it then submitted it.

I’m going to try it again for a simpler puzzle incase it’s something to do with the puzzle shape

testing again
solved puzzle not yet submitted

solved puzzle submitted

(no perceptable change to the screen for me) and png still showing red and green in the hook

and now just going to player puzzles and clicking play now, play now, start here’s what I see

which is all AAA locked in the hook

just bumping this - as TBmanXII asked me about it a couple of days ago - it happened to his puzzle Rings 456789 http://eterna.cmu.edu/eterna_page.php…

I mentioned it was a bug