Support for pre Intel Macs?

The tutorial puzzle loads but then the screen stays blank.
I have an older Mac. Does this work for Macs without an Intel chip?

Do you have the latest version of Flash installed?

Adobe Update

sandyr, I think this problem might have been fixed. Can you try again and let us know if it still doesn’t work?


I am having this same problem. Any update or suggestions?

It appears that Pre-Intel Mac owners are screwed. Flash 10.2 was recently rolled out & there is no support for Pre-Intel Macs.

This is lousy, aggravating, and just “insert expletive” wrong. With Flash being incorporated into everything these days Pre-Intel Mac owners will be left behind when it comes to web usability unless they go purchase a new machine.

Bottom line is - this sucks.

I could update Flash and that solved my problem.

I have a G4 MDD running 10.3.9 and the most recent version of Flash supported in 9. Unfortunately, many developers are creating Flash navigation & sites that require 10 or more recent. Youtube is non-functioning on this G4 running 10.3.9.

Then there’s the PPC G5 tower running 10.4.11 which was able to be upgaded to Flash 10.1 … but since it is not an intel Mac, I cannot install any future Flash updates.

I appreciate your concern, but I think I responded to you that I did get a Flash upgrade and so could download and solve eteRNA puzzles.
I can’t get Flash on my iPad (it was free, I didn’t choose it) but I hope that the video field will soon move beyond the Flash protocols.