Unable to load tutorials

Hello. I am unable to successfully load the tutorials. It appears to go through the load countdown but then no image/page appears. Do I need to adjust the settings on my brower (IE8). Thanks.

Hi stretchtime

EteRNA requires a flash player version above 10 - you can get the player at


Let us know if that doesn’t solve the problem!

EteRNA team

I have version The tutorials are still not loading. Thanks.

No reply on issue. Adobe Flash 10.3 running. still no load of tutorial. Please let me know how to fix. Thanks.

Hi stretchtime,

we are trying to figure out why that would happens in IE8…meanwhile, a quick solution would be to try the game in FireFox or Chrome.

We are sorry about the trouble.

EteRNA team

I have Flash 10,3,183,10 in Chromium 12.0.742.112 Ubuntu 10.04. Getting the same behavior – choose first tutorial, nothing happens.

Hi ts3982ad

When you enter the tutorial - do you see the chat box on the upper-right corner and little bubbles in the background?

We are very sorry about the trouble. This bug has been added to our bug tracker with case ID 533 - we’ll try to fix the problem as soon as possible!

EteRNA team