Alt Key not working in Ubuntu

I’ve reached Level 8 in Liquid Robotics, but cannot go any further as I’m asked to use the ‘Alt’ key and then left click the mouse, which unfortunately does nothing.
Can’t go any further without this and have no idea how to resolve this.

1 Like

It might help you to do a reset of the puzzle. Chose Reset under the 3 lines menu button. While I wasn’t using Ubuntu, this level was bugging me too. The puzzle appeared to get stuck and nothing I did would change anything in the puzzle. I did a reset and the tutorial started running again and reacting to inputs. Hope this helps, else throw in a coment here again.

Tried that without success. I think it’s Browser (Firefox) of Flash related as the Alt key works outside the browser (i.e. Alt-Print takes a screenshot of the current window correctly).

OK. Seems to be a gnome issue.
Tried to solve this by following this link Problem is it doesn’t work and screws up all other windows in the process.

Someone else had posted about such an issue with Linux Mint. Does the suggestion there help?…

Unfortunately now. I saw that post, but the fix doesn’t apply to Ubuntu 17.04 running Unity. I’m also checking in the Ubuntu desktop forum

Is it possible to make scroll-wheel click do that? that seems to be an important enough of a problem for it.
@leopoldi maybe you could 1. boot windows or 2. emulate windows and bind your tab key to alt? these seem to be the only solutions I can think of right now. if all else fails maybe ask for an option to skip that level, but alt click is pretty important, so it should be the last resort.

I no longer have a Linux or Ubuntu machine to test this, but try holding down the shift and alt keys and do a left click.  Good luck,


Thanks whbob. Your suggestion works.
Another workaround is to change the gnome default for mouse-button-modifier from to via dconf-editor.
I prefer your solution as no changes are need.

@leopoldi171254: That’s great.  Looking forward to seeing you in the labs very soon :slight_smile:

Glad to hear you found a workaround! I’ll make sure to reference this to anyone who runs into this in the future. Hopefully at some point we’ll have customizable key bindings so that it will be less of an issue!