Bug reports

I found some bugs lately/ old ones that I never got to report for some reason (whoops). So here they are:

  • Whenever I edit a script, it changes type to etc (in the url it shows the correct one though). When I create one it’s puzzle solving like it should be, although I do think it should be changed to etc or to booster.
  • The locked “Enter Lab” and “Explore Projects” in a new player’s home page are active, while still being half grey.
  • Lib.fold doesn’t work: http://imgur.com/a/S1r7T (I only encountered it a few days ago I think, I used it in the past and it worked)
  • once my inputs got corrupted and now they return only the first input: http://www.eternagame.org/web/script/edit/?id=8024679&type=Etc. I think it is solved by removing them and adding them back, but I’m not sure.
  • I can’t remove inputs that were added before I started editing the script.
  • When hovering over player puzzles, etc. on a new player, it say that I need lab access to use those features, while I actually only need a certain number of points.
  • While not really a bug, when searching for a script, it sorts by % of solves instead of by date, which is almost never useful, as it brings all of the puzzle solving scripts to the beginning.
  • Sometimes scrolling the puzzle progression to the right (mouse from right to left) is much slower than to the left (mouse from left to right). I will link to a video when it will happen to me again.
  • http://www.eternagame.org/certificate/228064 this is just plain wrong… (my highest is much lower than 87, the percentile is wrong, I never reviewed papers)
  • Getsat removes the post draft if I log in after clicking post (it asks me to login when I click it)
  • Not really a bug again, but when I click next on a puzzle it transfers me to the next one overall, instead of the next one in the category / search I was in.
  • Send message appears in all of my profile pages except for the About Player one (the main one which doesn’t have a subfile / subfolder in the url)
  • I get this error in every single puzzle: http://imgur.com/a/HhM3D
  • wrong year :P http://imgur.com/a/3IOV4
    I will add more if I will find / remember any other ones.

thanks! adding these to our list of bugs.
The lib.Fold bug is probably mission-critical if folks want to use scripts to fill out openCRISPR slots.

If I might jump on the glitch train for a sec here:

  • When Caleb was playing around with a mobile version of the site, it seems he added this meta tag to the head of all Eterna pages: ‘’ This prevents scaling. Since nothing on Eterna is mobile optimized, this makes browsing the website even more of a pain on mobile. Please remove this
  • The newsfeed has gone a bit wonky. Recently I noticed that (when browsing “all” at least), that when I opened my PM chain with Rhiju, it pushed older messages in the thread lower than other posts (other PMs, news/blog posts, etc) that were newer. What I would expect to happen is all the messages in one thread to be grouped together, and that whole “block” to be put in the order based on the timestamp of the most recent message (like it used to :slight_smile: ).
  • In addition to that, for some reason, now when I load my newsfeed, only two items show up: http://prntscr.com/gdd132 Then when I load more messages, that CRISPR blog post gets duplicated. And even then, when filtering directly by message, I definitely have a newer PM that didn’t show up even when I hit load more messages: http://prntscr.com/gdd1mt

Also, per the getsat-related items:

  • Post draft - If you click post, then log in, it should just post the comment. If you aren’t able to log in, afaik the whole login thing happens in a new window, so the draft should still be there. Is there something I’m missing?
  • “Wrong year” - This was a community announcement from last year. The thing that shows up there is the last announcement in the given category. That said, it shouldn’t be filed in game (will fix that). I can change all the old community announcements to articles, since none of them are really too relevant anymore - would people prefer that over having them being “correctly” categorized?

You already know this, @MaserStormer, but I’ll post it here for the record.  Re Lib.fold, the Player-Driven Development team (with special kudos to LFP6) figured out the problem and the fix is actually pretty simple.  Hopefully, the fixed version will show up in the first part of next week. 

If anyone is getting the error message “Lib.fold is not a function” in an Eternascript and you don’t want to wait for the generic fix, http://www.eternagame.org/web/script/8234765/ illustrates how you can work around it.