Feedback thread for the upcoming NOVA port update

Please post bug reports, feedbacks and/or comments here. Thanks


The “unique barcode” while designing a lab submission isn’t working as I expected it to. I went to… and selected a lab for view/copy. At this point, the bar code should be a duplicate, but it isn’t diagnosed as such by the widget in the upper left. I tried publishing the design (with no mods) and there it was rejected as not having a unique barcode, as expected.

Opening and closing the chat window has always been a sore point with me; the hot spot area doesn’t align with the visible icon. The new version is no worse than the old, but since you are in the code, I’d really appreciate it if you were to expand the responsive area so that clicking anywhere on the visible icon, at least, would work.

1 Like

This feature is hard to test properly, because the state of the round and which barcodes are currently used on that server instance may not match. Thanks for the report but there’s little I can actually test before we’re live.

From the testing I just did, I cannot reproduce what you’re saying: the clicking area does match the icon.

But I agree that it’s a hard one to hit precisely. I will look into enlarging the reactive area for this button.

1 Like

Is the database used while working on the design different from the one used when it is submitted?


I can’t really tell, but I verified that the applet reacts properly to the list sent by the server when the puzzle is pulled. On the prod server, that list is maintained consistently, but I strongly doubt anyone cares to do the same on the dev server…

I increased the clicking area by 255% (from 12x6 to 16x16). It’s still small, but things should be slightly better.

1 Like

Superb! That’s everything I could want. One fewer frustration in life! Thanks again.

It should have been done a long time ago, sigh… My pleasure :slight_smile:


I noticed something else not related to the port, but seems like low hanging fruit at this point. When viewing the dot plots for a switch, the lower triangle (MFE) updates according to the state, but the upper triangle (base pair probabilities) doesn’t.

Since I am gathering increasing confidence that the two dot plots can be interpreted in a way that is very predictive of the lab switch fold change, this seems more important than it did in the past.

It may seem like a low hanging fruit, but unfortunately, it is everything but.

The matter of fact here, is that, to my knowledge, there are no folding engines with proper support for ligand binding. It is not included in Vienna, and I never saw that feature in any other folding engine.

In EteRNA, we never had more than hacks coded by Jee. The very first version was demonstrably quite poor. The current switch 2.5 version of the hack gives acceptable results in most cases (I can give an example where it fails though), though limited to MFEs. No partition functions.

In simple words, this hack can’t compute the partition function of sequences in the presence of a ligand like FMN, and its accuracy for MFEs suffers from a conceptual flaw.

I’ll mention again my personal effort at which is meant to address precisely this problem, but this is not available in the game.

If all you need are dot plots, then may I offer collaboration? It is probably deactivated now, but I once had a nodejs script running on a cloud server that had just that function: produce (hopefully accurate) dot plots, given sequence and ligand+concentration. Would this help?

I’m definitely interested in estimating the partition function of the bound state for the purpose of predicting Kd values in the MS2 labs. I have yet to get any experimental validation, but my plan had been to use the pair probabilities generated by Vienna’s partition function evaluated for the sequence with the FMN constraints. Although I can appreciate that using the constraints is not exactly the same as using the actual ligand binding, it seemed like a reasonable approximation. Is this not the same aproximation nando.eternadev and the game UI use to calculate the MFE for the bound state?

I have looked at, but not diff’ed it against the original in order to understand your mods. Did I scan right over the explanation of what you did? Unfortunately, that happens.

(This discussion has wandered from the original topic; I’m fine with moving it elsewhere if you prefer.)

Update: I went back and looked at the switch-scores-for-eterna-switch-puzzles topic and see that 7 days ago, you did explain the differences I was asking about.

(I’m fine talking about it here, as long as we’re only commenting on your original feature request)

The thing is, neither Jee’s method, nor my constrained folding trick can work for partition functions. A constrained fold just skews everything, but it can work for MFEs provided you’re careful with what you’re doing (checking bonuses and differences in free energies). Jee’s switch2.5 method is cleaner, but for one, he didn’t bother extending it to the partition function part of the engine, and anyway, it still fails in regard to partition functions, because the calculations are based on a localized binding site.

Take the switchmaker, paste these 2 structures:
and then, paste this sequence:

Now add the molecule where it belongs. It works right? The applet would gladly let you publish the puzzle, but in fact it should not.

Remove the molecule, and paste this sequence in place of the bound state:

With the above sequence, and in presence of FMN, *this* should be the MFE. The original puzzle should NOT solve with that specific sequence. That’s the flaw in Jee’s algorithm, that I tried to carefully address in vrna-hack.

And my Vienna hack is the only way I know of to get proper partition functions when ligands are added to the solution, because it will consider all possible binding conformations, not just a single pre-specified one.

Hi Nando!

Thx for the chatbox turn on and off in the gears. Big tumbs up for that.

I also like the highlight of unsolved areas directly in the puzzle, as an alternative to enlarging the minimap. It is now very visible where the problem is. :slight_smile:


Ok, I also have a big problem to report. :slight_smile:

One of the new changes has broken the lab archive and made much harder accessing the lab data and do analysis. Usually there were a persons symbol at top middle of the screen. But it is gone now. Instead is a lab list button at the bottom. But this does not do the same thing.

All I want after seeing the lab design I looked up is to get sent directly back to where I came from and have the lab list as I sorted it. Count: 1 click.

The persons button at top middle screen worked for that. It sent me back and nothing was changed in the lab list and I could go on watching designs. And the lab list was sorted as I had it sorted and with what ever number limits I had put as filters in the columns.

What happens instead:

Click 1: Instead I’m send to the web version of the lab list.

Click 2: A new window opens. I have to get back into the classic view

Click 3: I have to close the window with the design I came from

Several clicks later: I have to reset my sorting of the data all over again

Additional click: Open next lab puzzle that was all I wanted was to get send directly back to where I came from so I can get on with watching the next design on the list, after whatever sorting criteria I set up in the first place.

And all this just to get from one design in the lab list to the next.


Solution suggestion

Get the lab list button send us to classic eterna lab list (or web for those who so wishes) like the persons button did before. I just want what ever link was attached at the previous person button to replace that in the new lab list button.

Why I don’t use the web version of the lab

The web version of the lab list isn’t working for many reasons some of them brought up in here and a lot of those have not been fixed:…

Just to highlight a few of the most serious:

  • One can’t shift between SHAPE and base colors in just one click, it takes multiple.

  • If I do tiny changes like change between SHAPE colors and base colors, then I have to input all the numbers I used for sorting in the columns all over again. Web version is as usual eterna - but with absolutely no memory.

  • When shifting back and forth between functions like base colors and SHAPE, the screens don’t overlap and remember where I was looking, when I shift between SHAPE color and base color. In the classic lab list, the position of the lab list doesn’t change, just SHAPE color and base color.

Imagine that the design turned up in two different corners of the screen when you do a simple shift between base colors and SHAPE and not overlapping as it does normally. Thats basically what happens for the lab list.

The return of the jedi

The more clicks we have do to just get at the design/data and the more tedious it is made, the less work we can do.

May the force guide you to minimize all the clicking :slight_smile:

1 Like

As a matter of fact, Eli, the only things I changed for these buttons, are their appearances and their positions. Specifically for this button, I’m positive that I didn’t touch the functionality. The “send to the web-based lab browser” action was implemented before I started accessing the code back in December, and I didn’t touch it at all. This means, it’s been like that for many months, and this was not a part of the Nova update.

This said, I agree that it doesn’t make much sense to go to the web-based list when you came from the Flash applet… There’s probably an easy fix, I will look into it.

Hi Nando!

Yes, it has been a big problem before, but for a while it has somehow been gone. Not sure what happened then. It maybe a problem for some labs and not for others. It has been happening before. Usually the active labs are not touched by it.

Crossed fingers for you and it being an easy fix. It will make things a lot easier for us.

Big thx!