Liquid Robotics - Level 10 of 11 - Does not load model

When I go into Liquid Robotics, Level 10 of 11, the screen loads the Chat/Online Box and 2 hyperlinks overlapping (Go to Home, and [Liquid Robotics] Level 10 of 11), but nothing else.  I have tried clearing my cache and browsing history, but without luck.  It does the same thing every time I go in.  I am not sure if it is something with my browser, or if this model is broken. I have not had issue with anything else.


Yes, I have confirmed this bug on Windows 10 64bit, Version 1903 using Firefox 70.0, Edge 44.18362.449.0 and Chrome 78.0
The webpage is definitely broken! If you click on the Level 10 of 11 link at the top left, you end up in an infinite loop!

Hi all, thanks for bringing this to our attention - I’ve found the problem and am working on a fix.

A fix has now been deployed! Please let us know if you have further issues.


this bug is back I’m afraid. I’ve tried with chrome and firebox on macos and both fail to load. It looks from a quick peek at developer tools that some bad javascript is being served for this lab.

Cheers, Cos.

1 Like

Yep, the bug is back, unfortunately. Both myself and Hoglahoo have tested it and have been unable to access the puzzle.

1 Like does not have the Home icon in the top left. Just the words [Liquid Robotics] Level 10 of 11 . The puzzle itself does not load. It will display an inspirational quote like it normally does but then nothing else loads. 

Hi all - we’re aware of this issue, and a fix has been started. We haven’t been able to finalize this since I’m responsible for making that happen and I’ve been on vacation this week, but I’m planning on getting this fully resolved when I get back on Monday. :slight_smile: Congrats on getting that far through the puzzle progression by the way. Thanks for your patience!

ok, thanks for update, I’ll check back later today or tomorrow.

Hey all! Just deployed a fix in v1.7.3. Let me know if you run into any additional issues!

Thanks, it works fine now!

Thank you!