Old user login = dividing by zero ( slooooooooooooooooooooow )

To whom it may concern,

Logging into eternagame.org on mac sierra safari takes 23+ seconds, plus additional 30 - infinity seconds load time for all home page content ( i.e. not loading the top mastering eterna options, though once it did render them ). 

same system, firefox, waited 3-4 minutes waiting on log in, gave up, no successful login.

Will try on another computer some time. Tried with new user, login is almost instantaneous.

Therefore, possibly something to do with preloading all user content on login? Consider loading only credentials, home page on login, and doing staggered load for past completed puzzle history, labs, etc.? I don’t know how it works or if this is remotely related to the issue, just a guess. Or perhaps related to old users starting on cmu server, and a port gone awry? Again, I am saying words which I only know a little about, so someone who devs the devvy devviness will have to evaluate and propose a solution.

A) If a new user has this issue, who also has a lot of completed puzzles, labs, messages, comments, or other user content ( as opposed to a new user with little content ), then that would suggest it is an issue with loading user id’d content on login.

B) If an old user has this issue, who has submitted relatively little content, that would instead suggest it may be a port or other issue.

=> This is an issue because our institutional knowledge in old players is indispensable, as the learning curve to switch labs is steep, and they went up the smooth learning curve, not the cliff for new users. And if they try to log in after some time, to find login, page loads, and even external page links ( e.g. to the wiki ) to take forever to load, they will surely never make it through labs, and the barrier to entry will further decimate an already niche user base.

I tried to review results on my old synths for example, and gave up on most of them loading, though some did get there. I tried playing new player progression puzzles, as well as the first recommended puzzle in mastering section, and submission likewise took forever. In the first case I gave up, in the second I waited the 30 seconds out of curiosity, and did eventually see the puzzle submitted.

While I would not be surprised if using a newer, non retina, or non sierra os computer functioned better, the fact that the new user account loads instantly and my old account takes forever, makes me suspect something endemic to eterna’s code, and therefore potentially fixable. :slight_smile:

Next time I try to log in at another computer, I will update if I get different results.

Anyone else who has slow loading, please feel free copy and paste this form into your comment with any info you want to share. I put my own results in.

operating system: mac sierra
browser: safari ( firefox never got past login )
old or new account: old ( brand new zero submission user 1-2 seconds )
many or few puzzles / labs / comments submitted: many ( puzzles, labs, & comments )
time to login:  23-30 seconds
time to load home page:  4 seconds - 2 minutes, gave up on loading Mastering contents
time to submit completed puzzle:  30+ seconds - gave up
time to load labs results page:  2 - 4 seconds ( lab with 1 sublab loads fastest, lab with many sublabs slowest, suggesting loading any quantity of content in this system is not being handled efficiently )
time to load synth results: 3-5 second average, one never loaded ( gave up after a minute or two )

It appears that the primary issue is the handling / loading of larger quantities of data, regardless of datatype, and subsequent consequences may be disproportionately affecting those who have submitted more content. But then, I have no idea, so good luck!


 ~ elves

p.s. several seconds is too long also, just in case those times look short compared to the others. This is the age of instant gratification, and slow loading videos and websites are simply abandoned for other immediately accessible content. So, while this might not seem high priority compared to having a generally functional system ( good job! ), please be assured that few people would have the patience for this. For example, I find it frustrating enough that if I don’t get another computer to load the pages faster, I will probably not have the patience myself, despite caring very much about the project.


Hey Elves, good to see you around.

I have noticed increasingly slow loading times, but honestly hadn’t connected the dots pointing it towards loading old user data - that actually does make sense. I’ll try to do some digging once I have a little time to see where exactly the slowdown is stemming from - would not be surprised to see some extremely large, inefficient API request or few.

This is definitely a significant issue, thank you for bringing it up. I personally have a limited amount that I am able to do right now, but hopefully I can at least get the process rolling to get it resolved.

1 Like

You too, LFP6! :slight_smile:

I am delighted to hear you have some good clues as to what might be going on, thank you for considering the issue.

Please don’t overextend yourself, we all must take good care of our primary responsibilities and self care. :slight_smile: I am really grateful for the time and immense work you have already given.

And as time is available, anyone who can solve this problem will vastly improve accessibility to the players who have submitted the most content, and I think we all know what that means to the longevity of the project.

A special side note to those who are not having slow loading times:

If you get a chance to fill out and comment with the short form I provided above, that information will still be helpful to us, in narrowing down the cause of the issue, even if you yourself do not have the issue.

Alright, so I don’t think this is what I expected. The login doesn’t have any data associated with it, so that definitely doesn’t follow my hypothesis. The side_project_roadmap and get_labs_for_my_lab_cards queries seem to be taking ridiculously long and don’t seem to be carrying that much data or require a ton of processing. So this isn’t really what I expected.

I just tried what you did with both my current and test account (the latter barely used), and I definitely see the issues that you’re raising. While I don’t see times anywhere near what you have (puzzle submission and login times at 15 seconds, home page winds up being probably ~30 seconds which I can almost deal with), using a fresh account is maybe 10 times faster on all counts. I wouldn’t be all too surprised if the increase in time that you see is due to the fact that you’ve used your account more (ie, played more puzzles).

Something must have changed server-side in the last couple weeks to couple months (I believe this slowdown is that recent). I don’t have the access to do any further debugging myself, but I’ll try to run this past Omei to see if he can get a message to the dev team about this.

Thanks for your patience with this.

1 Like

Using Win10/Chrome myself

Wow, that was a fast and helpful place to start investigating, thank you so much LFP6!!

Getting the confirmation that it is not only my computer helps, even if we aren’t sure what is going on yet.

Any magic Omei & other devs can apply to divine the source of the issue would be most appreciated. 

For my own part, there is no rush. But if I am not alone in this, then I am sure other players might appreciate if this were to be addressed whenever possible.

Just talked to Hoglahoo in chat. He said that he’s seen a significant slowdown in load times over the past year or two, 5-10 seconds per page. 12-second homepage load, 27-second login, and 22-second puzzle submission. Not crazy based on his activity, but notable nonetheless.

1 Like

Hi Elves!  Good to hear from you!

Here’s my results for the survey:

operating system:
 mac sierra version 10.12.5
browser:  Chrome
old or new account:  old 
many or few puzzles / labs / comments submitted:  many 
time to login:  10 seconds from clicking login to home page appearing
time to load home page:  10 more seconds for home page to completely fill up
time to submit completed puzzle:  15 seconds 
time to load labs results page:  1-3 seconds 
time to load synth results:  This one can be really variable, because there are three possible different browsers, with different sets of capabilities, each with their own capabilities, that can get invoked.  It used to be that you could only look at results for one puzzle at a time (the Flash browser). but now, there are a lot of links that bring up the legacy HTML browser, the one whose heading looks like this.

If you get that one and it is loading much data, you can be in for a very long wait, regardless of your machine.  It’s always been that way; it never really got finished, and no work has been done on it for years.

Compared to my “typical” expectations, I would say this is a little faster than average.  There are times when I experience unusually long delays, most often when submitting puzzles.  But they are the exception rather than the norm.

Can you try with Chrome and see if that makes any difference?  I don’t know about the Eterna site as a whole, but I do have access to the analytics for the new HTML browser, and it shows 95%+ of users their using Chrome.  I don’t have high hopes for this hypothesis, because I occasionally fire up Safari and Chrome for Eterna, and have not noticed a big performance difference.  But it is one way your experience might be slower than mine.

1 Like

Thanks LFP6 & Hoglahoo, this is helpful data indeed. :slight_smile:

Hi Omei, good to see you around too! :slight_smile:

Thanks very much for supplying your results, context on synth loads, and suggestion to try Chrome. I will check that out.

I think something about the mbp retina rendering is slower and hotter in flash, so that may the part of the hangup on my puzzle submission time.

Also, sierra seems to have a windowserver bug creating a black hole for mem & winding up processor - a couple weeks ago and also just now when I checked though I was too slow to grab a screencap, windowserver privatemem or sharedmem I don’t recall which flashes out to an uncapped number of digits… ( when selecting info button to view process stats under memory in activity monitor ) may be a bug with no teeth, or may be a black hole, but processor spikes at same time as observed mem surge. This issue was so severe that my computer was freezing and unusable if I had many windows open, switching between windows / apps / desktops. 

Here’s my notes on what stopped the freezing, though apparently not the [appearance of a] black hole:
windowserver mem hole fix:
( in activity monitor I saw windowserver private mem spike out intermittently at a truncated 10-20 digit long number of MB, GB, or god knows how large - maybe this is normal, and unrelated to the freezing? )

  • Quit stickies app, since I had 50+ sticky notes, maybe not playing nice with memleak in windowserver
  • Toggled off automatic graphics switching in system pref Energy Saver section. I usually have this off, sierra may reactivate as default?
  • Toggled off transparency in sys pref Accessibility section ( this did not initially resolve issue, while above options did. possible to reactivate transparency, though this is the first recommendation for troubleshooting online ).

So there is an active and unresolved issue with managing windows in sierra, I don’t know if this could contribute to my higher wait times, due to frequent rendering changes, or if windowserver is uninvolved until actively switching windows. I’m just guessing at anything that could be remotely related. It would not explain anyone having a slow load on windows, so I would imagine it is only a contributing and not a source factor.

Thanks for your detailed reply. Will try to post chrome results later this week.


p.s. pro tip for windowserver issues I have seen in at least 2 OS versions in the last 4 years: clicking on the body of an app window does not correctly assign target, and keyboard strokes go to previously selected app. selecting menu bar of window instead correctly toggles focus. This one drove me nuts until I figured it out last time, and I would not be surprised if current windowserver issues are related to same bug not being fully resolved, or ghost fragment, because I noticed similar behaviour while investigating freezing in sierra ( selecting window in body not menu = no focus transfer ). I am no longer losing focus since disabling auto graphics switch, so perhaps there is in fact a memleak and it can’t keep up with requests? Again, scraping the bottom of the barrel on my knowledge here. Hopefully the right clue will come along. 

Your mentions of upgrading to Sierra, liking to have lots of windows/tabs open at the same time, along with memory usage and CPU spiking together, reminds me a lot of my own experience – which boiled down to just not having enough physical memory to support my habits. I was able to fix that by simply doubling my physical memory, which I could do because it was an iMac; you may not have that option.  :-(  

Something I became aware of in the process of diagnosing my own issues was that there is definitely a memory leak somewhere in the Eterna/Flash/Chrome/Mac stack. Once I knew to look out for it, I could see memory usage rising into the red zone and the Chrome Flash helper thread rising to 100% utilization.  If I let it go far enough, the whole machine would crawl to a stop.  But if I killed off the Flash helper thread, a whole bunch of memory would be released, and I could reload the Eterna pages and continue.  This was happening even before Sierra, but it got bad enough with the Sierra upgrade that I needed to take further action.  Memory consumption still increases over time, but I have enough headroom that my normal power cycling routine avoids the critical meltdowns.

1 Like

You are right, I am maxed out at 16GB ram due to being a laptop. 

I went to check out eterna in chrome, despite that I have been boycotting chrome, and found I have never installed it. So I went to install it, still thinking I would make an exception for eterna, but after reading the terms of service and externally linked privacy document, I just can’t bring myself to explicitly agree.

I know chrome is the new darling - thanks for the stats on our users, it’s a bit unnerving to see such homogenous adoption of a single browser. So undoubtedly chrome testing is necessary. If I change my mind I will try it out, but for now I think I am not the person for the job.

btw I thought market share of chrome globally is lower, closer to 56% last I checked, so I wonder if it is our demographic, or if those on other browsers simply can’t access well enough to stick around. It makes me wonder if testing was only done on chrome. Still, demographic may be more likely explanation, so this is only speculation.

You are also right that I did the sierra upgrade recently, having been slow to adopt due primarily to that losing focus bug I had a couple OSs ago, and finally having a stable-ish system with the previous OS. Within hours of beginning real work on sierra, I got freezing, though at least not kernel panics like before.

I think if I won’t use chrome, it sounds like I need to get a system with a lot more ram. I think my alienware laptop may already have 32GB ram, so I’ll try that out as my next step. But most people access the web on lightweight systems, so if we are to truly democratize access to citizen science, perhaps some computation will need to eventually be done server side - otherwise, I am not sure how any average system can get fast load times and not overheat or otherwise lag out.

Glad to hear you got your system back. And yes, any flash, and google video, and skype also overheat my system, for the record. Pretty much any intensive video / graphics. Oh yeah, I got my alienware because I could no longer do any 3D dev or rendering without screen tearing, and even fully black screen that can render nothing, plus ubiquitous 98C temps.

I suspect the last few mac OS releases have been a bit sloppy with regard to handling rendering on retina screens & window / memory management, and so I doubt the issues are entirely with eterna’s code. However, regardless, the game is nearly unusable in my expectations of load time. So if we do find how to pick up slack in the eterna part of that stack, then that would be fantastic.

I really appreciate you articulating your thoughts on this, thanks for your contribution. I am hopeful that if we outline what info we do have, that then we can send this forum thread to devs and give them as much of a head start / clues as possible.

And I apologize that I cannot yet bow my neck to our data overlords.

well it looks like a friend installed chrome on my alienware without asking me >.< but the upshot is that I tested eterna. 15 sec login, but loading the full home page takes 30 sec.

Firefox on this 32GB mem machine still takes 30 sec login, and 30 sec home page load.

I think the only improvement that would affect anything is not overheating as bad as the mac, but FYI whatever the slow load time issue is, is still an issue in chrome, as well as a higher mem machine.

I feel like this is a critical path issue, because I don’t know how many players have that kind of patience. 

Thanks everyone who provided their comments, and good luck to anyone attempting to address this issue!

Hi ~elves, 
I had a couple of older computers using Windows 7 that I updated to W10.  I had Internet Explorer.  Flash was not playing well at all with the two computers.  I installed Linux Mint on both and used Firefox as the browser.  Adobe Flash was going through upgrades quite often.  Each change in Adobe Flash brought slow motion in Eterna challenges and labs.

I tried Safari and it was faster, but every so often it wouldn’t work on the puzzles.  I had to do several things to try to clear memory, get latest versions of browser & Flash etc.  I could never get a reasonably fast system for very long.

I changed to a Mac Mini, Sierra OS v10.12.5, 4GB memory.  I installed Google Chrome for a browser.  I set up Chrome to ask before allowing Flash to be used for any program.  I only allow it for Eterna.

After entering my username and password it tales 10 seconds to completely load my home page.  

1 Like

There is a way to use the Chrome Browser Development Tools to see what is loading and how long each item takes to load your home page.  I don’t want to try to list all of the steps here, but if you get to perform this process, it will list all of the things that loaded and how long each takes.  That should let us know where your computer (using Chrome Browser) is stalling.  

Once the processes are identified, it will still be an adventure to find out why something is slowing the load time down:)

Let me know if you want to try the development tools & how we might proceed.

1 Like

I have actually done this myself, and found a few queries that were causing issues: https://getsatisfaction.com/eternagame/topics/old-user-login-dividing-by-zero-sloooooooooooooooooooo…

Oddly enough, when testing some other random queries, the lag fluctuated a LOT, ie a ‘type=user’ query might take half a second one time, then 7 seconds another. It’s really weird.

1 Like

Thank you whbob for your report. That is helpful. Thank you for the suggestion to use dev tools to see where it is hanging - is the same thing possible in Firefox dev tools? I have already uninstalled Chrome, and will not be reinstalling it, since I did not approve of their ToS in the first place.

Thanks LFP6 for the note on the weird fluctuation - any anomalies that can be reported may help narrow down the issue. 

np ~elves,

Reading over your “platform issues” post now.  I haven’t used Firefox since I was trapped in Firefox refusing to allow Flash unless I updated to the latest version of Flash and the latest version of flash rendered Eterna unusable on my computers.

Although I have not had delay problems with the home page and labs, I just tried to enter the lab archives.  I clicked on “review results” rather than the other choice that lets you select individual labs.  “review results” took me eventually to the new data browser.  It took 2 minutes! 12 times slower that loading other pages.  It was only 30 seconds waiting to reply and download the data, but another minute and a half with the blue page frozen until the spreadsheet appeared.  Trying to scroll was not pretty.  A buffer kept the scroll going long past my mouse moves.

I don’t know if the secure server is any different from the non secure server. Probably not.

I feel your pain:(  

@whbob What you got that took 2 minutes and 12 seconds to load is not the “new” HTML data browser.  It is the “legacy” HTML browser, which has some terrible performance problems, as you discovered.  When I started work on the new one, I first tried to see whether the old one could be fixed, but decided a whole fresh start was called for.

Unfortunately, the new browser in its current state doesn’t have the parameter processing needed to plug into the main Eterna code’s invocation of a project-wide query. So the main Eterna code fell back on the old browser to satisfy that request.