Progress not updating

I’ve cleared all the puzzles from Next-Gen Sequencer to Microfluidic Chip, but they’re still showing as locked on the main page. If I go to the Next-Gen Sequencer group, for example, all the puzzles there show a green checkmark and I’ve even gone through and completed them all again, but it still doesn’t show the main group as Cleared.

Hey Merckun! Looks like this is because you haven’t solved Thermocycler Level 11 yet - you can do that at We should probably prevent clicking on future levels until you’ve finished the prior ones. :slight_smile:

Thanks for the reply! On my end, it actually showed the Thermocycler grouping as Completed.

It does that. it usually says you completed the level when you actually haven’t.

Or when you complete it, the Mission Accomplished screen doesn’t come up.

I did see someone else run into this with the same level - I’ll need to look into it

Of the Mission Accomplished screen not coming up? That happens to me a lot…

It won’t show up until the server fully processes your solution - you may just need to wait for a little bit to see it

We’ve identified the cause of the initial issue of a section showing as completed when it hasn’t been - a fix for that has just been deployed.