Unable to do puzzles (Issue)

Recently, I have been having problems accessing the puzzles. Whenever I do get to the page containing the puzzle, only the background loads (no animation). This is definitely a computer specific problem as it works wit other computers via the same account. Could you leave any possible solutions/ Redirections?

1 Like

Have you checked that this machine has a working Flash plug-in, and that it is enabled for the eternagame.org domain?

Past what Omei suggested, please provide your OS version, browser version, and Flash version to help isolate the issue (especially any of these that changed from the working computers to the one that isn’t working).

Just tested in Chrome, seems we’ve run into a syntax error:

Uncaught SyntaxError: Unexpected token ,

Pointing to this function:

function saveTutorialScript() { PageData.save\_puzzle\_tutorial(, document.getElementById('edit-tutscript-area').value); alert('Tutorial has been saved.'); }

The save_puzzle_tutorial call is the culprit there, as the arguments start with a comma.

@LFP6: The specific error you point out has been there for a long time, maybe months.  It has seemed to be benign in the past; I suspect it doesn’t have anything to do with StormTroop’s issue.

Yeah, so it looks like I ran into a completely different issue, out of random chance I just happened to find a broken puzzle. Any further information would definitely be helpful to track this issue down, hopefully we can find out where it’s coming from rather quickly.

It is still not working. It is not dependent on the Adobe Flash Player. No site limits are in place either. Started 3-ish days ago. Not Working: Windows 8, Internet explorer. Working: Chrome OS.

What IE version?Why do you say it’s not dependent on Flash? If you open the developer tools (by hitting F12) before going to the page with the puzzle, do you see any errors aside from the one I mentioned?

IE 11

Flash works perfectly on other similar websites.


HTML1527: DOCTYPE expected. Consider adding a valid HTML5 doctype: “”.

File: 6503038, Line: 1, Column: 1

SCRIPT1002: Syntax error

File: 6503038, Line: 71, Column: 51